model 1 working sega saturn does weird things.....

This is the place for anything about Sega Saturn
User avatar
NWA
Posts: 249
Joined: Sat Aug 13, 2011 3:18 am
Location: Gatineau, Quebec, Canada

model 1 working sega saturn does weird things.....

Postby NWA » Wed May 30, 2012 5:31 pm

hi all,

i just have another little story i'd like to tell on my experiences with sega saturn, so, her we go:

sometime around december I bought a CIB launch saturn (atleast i think its launch) for 80 dollars. My parents weren't too fond of the purchase, they expected me to get some games for my 360 with my money like my brother does (60-70 dollars for mw3? YAH.....I think I'll wait afew months and get a used copy instead, I mean common, I'd only be buying games new if the dreamcast 2 existed!) but I was super happy to have it, because my other sega saturn was acting up at the time (reading many games as audio cd's). i got home, plugged it in and it works great! but recently i've been wondering if someone had installed a mod chip in it, so i stuck in a burnt copy of DN3D. but sure enough, it went looking for copy protection, so i opened up the disc tray and the cd stopped..... then it started pinning it backwards. im pretty sure it got to the sega logo before i turned it off, i don't remember. can anyone shed some light on why it did this? I'd love to know. P.S, I OWN A LEGIT COPY OF DN3D. also, the serial number is B5 040653 and the manafacturing date is May, 1995.
Better run home to momma now!

User avatar
Warp2063
League Veteran
League Veteran
Posts: 1566
Joined: Mon Mar 03, 2008 4:28 am
Location: North Carolina, USA

Re: model 1 working sega saturn does weird things.....

Postby Warp2063 » Wed May 30, 2012 8:05 pm

No idea what happened there. Without some testing, I can't say much. It would be fairly easy to see if there was a modchip installed if you opened up the system completely and examined the ribbon cables connecting the drive assembly to the main board...

Unless it does it again, it may have just been a fluke.
I have my Saturns, I have some of my games, I have a RasPi. Gotta put all this stuff together!

User avatar
NWA
Posts: 249
Joined: Sat Aug 13, 2011 3:18 am
Location: Gatineau, Quebec, Canada

Re: model 1 working sega saturn does weird things.....

Postby NWA » Thu May 31, 2012 12:10 am

Warp2063 wrote:No idea what happened there. Without some testing, I can't say much. It would be fairly easy to see if there was a modchip installed if you opened up the system completely and examined the ribbon cables connecting the drive assembly to the main board...

Unless it does it again, it may have just been a fluke.


i've tried it multuple times but turn it off quickly because i'm afraid if I let it continue spinning the game in reverse, it could lead to serious damage. When I bought it, I tried to take it apart, but the PSU was stuck to the top part of the shell, so I closed it back up.
Better run home to momma now!

User avatar
Warp2063
League Veteran
League Veteran
Posts: 1566
Joined: Mon Mar 03, 2008 4:28 am
Location: North Carolina, USA

Re: model 1 working sega saturn does weird things.....

Postby Warp2063 » Thu May 31, 2012 2:57 pm

It's spun in reverse on multiple attempts? Yeah, something's really wrong, but I can't tell you more without running tests. Perhaps the power to the motor has been reversed somehow? Or maybe someone damaged the motor already.

The power supply unit itself was stuck to the top of the shell? If you're correct about that, that sounds fairly dangerous. Either it's failed... a lot, or someone's been tampering in there.

I recommend that you specifically go looking for working Saturns when you buy them. Unless you know what you're doing, fixing up a really complicated system is no easy task. I consider myself moderately knowledgeable, and I've made irreparable mistakes with an original Game Boy and a Game Gear. They still work, but they'll never work as well as they should.
I have my Saturns, I have some of my games, I have a RasPi. Gotta put all this stuff together!

User avatar
NWA
Posts: 249
Joined: Sat Aug 13, 2011 3:18 am
Location: Gatineau, Quebec, Canada

Re: model 1 working sega saturn does weird things.....

Postby NWA » Thu May 31, 2012 7:04 pm

Warp2063 wrote:It's spun in reverse on multiple attempts? Yeah, something's really wrong, but I can't tell you more without running tests. Perhaps the power to the motor has been reversed somehow? Or maybe someone damaged the motor already.

The power supply unit itself was stuck to the top of the shell? If you're correct about that, that sounds fairly dangerous. Either it's failed... a lot, or someone's been tampering in there.

I recommend that you specifically go looking for working Saturns when you buy them. Unless you know what you're doing, fixing up a really complicated system is no easy task. I consider myself moderately knowledgeable, and I've made irreparable mistakes with an original Game Boy and a Game Gear. They still work, but they'll never work as well as they should.


this saturn actually always works with 100% success rate though, but my saturn that shocked me also had the psu stuck to the top, there's a plastic clip molded ontop of the top part of the shell that holds the psu up there EDIT: it spins real games clockwise though. It will only spin backwards if i put in a burnt game, close the tray, power it up then open the tray again when its attemping to read the toc and copy protection label, But if its a legit game and i open the cd tray while its trying to read these things, it will stop, go to the bios dashboard and say "disc drive open".
Better run home to momma now!

User avatar
Warp2063
League Veteran
League Veteran
Posts: 1566
Joined: Mon Mar 03, 2008 4:28 am
Location: North Carolina, USA

Re: model 1 working sega saturn does weird things.....

Postby Warp2063 » Thu May 31, 2012 7:26 pm

It's been about four years since I looked inside my model 1, so I don't recall the location of the PSU.

If that's the only way it spins in reverse, then don't put burnt games in the system. Simple enough.
I have my Saturns, I have some of my games, I have a RasPi. Gotta put all this stuff together!

s41793
Posts: 1
Joined: Thu Aug 09, 2012 8:34 am

Re: model 1 working sega saturn does weird things.....

Postby s41793 » Thu Aug 09, 2012 8:39 am

Warp2063 wrote:The power supply unit itself was stuck to the top of the shell? If you're correct about that, that sounds fairly dangerous. Either it's failed... a lot, or someone's been tampering in there.


Early model 1 units had the power supply attached to the top of the shell

User avatar
NWA
Posts: 249
Joined: Sat Aug 13, 2011 3:18 am
Location: Gatineau, Quebec, Canada

Re: model 1 working sega saturn does weird things.....

Postby NWA » Thu Aug 09, 2012 5:38 pm

You're right
Better run home to momma now!


Return to “Sega Saturn”

Who is online

Users browsing this forum: No registered users and 1 guest